Secure 2024: Forrester Wave™ Q2 2022 Showcases Leading Bot Management Solutions
Resources

Understanding the Upcoming PCI DSS 4.0 Customer Browser Requirements

All Industries, Client-Side,

If your business accepts credit card payments online, you know about PCI DSS. But did you know that version 4.0 is coming soon? This update to the standard requires that you protect your customers’ information on all payment pages that use scripts.

In this video, we welcome, Troy Leach, SME at Cloud Security Alliance. He discusses the details of PCI DSS 4.0 with HUMAN’s Senior Product Marketing Manager, Robert Kusters. Together, they walk through the details of the upcoming changes in the standard, the challenges you may face in implementing the updates, and how HUMAN can make the journey to PCI DSS 4.0 compliance easy. 

View recording to find out more about:

  • The upcoming PCI DSS 4.0 customer browser requirements
  • How to easily comply with PCI DSS 4.0 requirements with HUMAN
  • Adopt a modern defense strategy to prevent script data leakage